Home > android > HTC Sense 3.0 not arriving on older HTC phones
CLEAN!

22 htc sense 3 HTC Sense 3.0 not arriving on older HTC phones

HTC’s powerhouse Android phone, the Sensation was recently given an official announcement and shown off in a video, showcasing the upcoming HTC Sense 3.0 UI. Well some folks saw the impressive looking Android overlay and wondered if it was ever coming to their Android phones so they shot a tweet to HTC that was replied with:

“due to Sense’s hardware requirements, only our newest devices (Flyer, EVO 3D, Sensation) will be able to support it.”

From the examples given, it looks like your current Desire, Desire HD, and even your new Incredible S or Desire S won’t be getting the new Sense UI. The EVO 3D and Sensation are both dual-core phones, while the Flyer has a 1.5GHz processor so it is assumed you’ll need a powerful phone for HTC Sense 3.0 to work. In case you were wondering about what the big fuss with the new Sense UI is, hit the break to watch the promo video:


Seen at: unwiredview  | Add a Comment   android htc   

Uberphones founders on    
 Eliane Fiolet   Hubert Nguyen 

Trending

    User Comments